How can we make MyEclipse fun and more usable?

Stop turning random stuff on when I update.

This is the second time after a CI update in the 2016 version that stuff has broken. If I want to turn a feature on I'll turn it on. First you automatically turned on some "live preview" crap that broke random crap, and now I have to deal with a bunch of .jsp files complaining after another update. Stop. Turning. Stuff. On. Automatically.

Part of the reason people bother using this IDE over IntelliJ is because it's cheaper. If the time our team has to spend fixing crap after an IDE update out weighs the cost of your competitors, we'll switch to them.

7 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Kody shared this idea  ·   ·  Admin →

    Kody, I agree that having an update break your workspace is extremely frustrating. However, live preview was the only feature in recent times that was enabled that could affect deployment. This was enabled only once, so if turned off, it would stay off, forever.

    With the 2016 CI 6 release, we fixed a bug, which, in some cases, could have prevented JSPs from being indexed and validated. Now that it has been fixed, perhaps you’re seeing these validation errors only now? Other than this one case, i can’t think of anything else that would lead to problems.

    Now, if these errors are false negatives, that’s another matter that should be addressed, of course. Could you please report the issue on our forums or feel free to comment further here and we’ll do our best to resolve it.

    0 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...

      Feedback and Knowledge Base